<!DOCTYPE html>
<html lang="en">

<head>

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

<!-- responsive -->


<link href='https://fonts.googleapis.com/css?family=Bitter:700' rel='stylesheet' type='text/css'>

<!--[if lt IE 9]>
<script>
// HTML 5 Shiv. for older IE - should be an if statement?  /
(function(){if(!/*@cc_on!@*/0)return;var e="abbr,article,aside,audio,bb,canvas,datagrid,datalist,details,dialog,eventsource,figure,footer,header,hgroup,mark,menu,meter,nav,output,progress,section,time,video".split(',');for(var i=0;i<e.length;i++){document.createElement(e[i])}})()
</script>
<![endif]-->

<link rel="stylesheet" type="text/css" href="https://www.autoguide.com/blog/wp-content/themes/autoguide/css/wrapper-2.css?v=1574349150" />

<link rel="stylesheet" type="text/css" href="https://www.autoguide.com/blog/wp-content/themes/autoguide/css/inner-pages-2.css?v=1559584189" />



<!-- This site is optimized with the Yoast SEO plugin v9.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
<title>How to Watch Every Racing Esport Event This Weekend » AutoGuide.com News</title>
<meta name="description" content="Digital racing is pulling in big numbers in these shelter-in-place times. Here&#039;s how to watch the biggest events this weekend in F1, NASCAR and IndyCar."/>
<link rel="original-source" href="https://www.autoguide.com/auto-news/2020/04/how-to-watch-every-racing-esport-event-this-weekend.html" />
<link rel="canonical" href="https://www.autoguide.com/auto-news/2020/04/how-to-watch-every-racing-esport-event-this-weekend.html" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to Watch Every Racing Esport Event This Weekend » AutoGuide.com News" />
<meta property="og:description" content="Digital racing is pulling in big numbers in these shelter-in-place times. Here&#039;s how to watch the biggest events this weekend in F1, NASCAR and IndyCar." />
<meta property="og:url" content="https://www.autoguide.com/auto-news/2020/04/how-to-watch-every-racing-esport-event-this-weekend.html" />
<meta property="og:site_name" content="AutoGuide.com" />
<meta property="article:tag" content="Esports" />
<meta property="article:tag" content="iracing" />
<meta property="article:section" content="Featured Articles" />
<meta property="article:published_time" content="2020-04-03T21:16:54+00:00" />
<meta property="og:image" content="https://www.autoguide.com/blog/wp-content/uploads//2020/04/Esports-Race-Weekend-2020-04-03.jpg" />
<meta property="og:image:secure_url" content="https://www.autoguide.com/blog/wp-content/uploads//2020/04/Esports-Race-Weekend-2020-04-03.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="734" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Digital racing is pulling in big numbers in these shelter-in-place times. Here&#039;s how to watch the biggest events this weekend in F1, NASCAR and IndyCar." />
<meta name="twitter:title" content="How to Watch Every Racing Esport Event This Weekend » AutoGuide.com News" />
<meta name="twitter:image" content="https://www.autoguide.com/blog/wp-content/uploads//2020/04/Esports-Race-Weekend-2020-04-03.jpg" />
<meta name="twitter:creator" content="@kylempatrick" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/www.autoguide.com\/","sameAs":[],"@id":"https:\/\/www.autoguide.com\/#organization","name":"AutoGuide","logo":"http:\/\/www.autoguide.com\/blog\/wp-content\/uploads\/\/2019\/08\/autoguide-logo.png"}</script>
<!-- / Yoast SEO plugin. -->

<link rel="amphtml" href="https://www.autoguide.com/auto-news/2020/04/how-to-watch-every-racing-esport-event-this-weekend.html/?amp" /><link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="AutoGuide.com &raquo; How to Watch Every Racing Esport Event This Weekend Comments Feed" href="https://www.autoguide.com/auto-news/2020/04/how-to-watch-every-racing-esport-event-this-weekend.html/feed" />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.11.3/jquery.min.js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/jquery-migrate/1.3.0/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://www.autoguide.com/blog/wp-content/themes/autoguide/scripts/scripts-trimmed.js?ver=20191218144852'></script>
<link rel='https://api.w.org/' href='https://www.autoguide.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.autoguide.com/blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.autoguide.com/blog/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://www.autoguide.com/?p=815926' />
<link rel="alternate" type="application/json+oembed" href="https://www.autoguide.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.autoguide.com%2Fauto-news%2F2020%2F04%2Fhow-to-watch-every-racing-esport-event-this-weekend.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.autoguide.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.autoguide.com%2Fauto-news%2F2020%2F04%2Fhow-to-watch-every-racing-esport-event-this-weekend.html&#038;format=xml" />
<!-- <meta name="NextGEN" version="2.1.23" /> -->
<link type="text/css" rel="stylesheet" href="https://www.autoguide.com/blog/wp-content/plugins/simple-pull-quote/css/simple-pull-quote.css" />
        <script src="https://www.google.com/recaptcha/api.js?render=6Ldi-KYUAAAAANoy8R5hUZ6_UqKfMZdzZjaKAdcJ"></script>
        <script>
            grecaptcha.ready(function() {
                grecaptcha.execute('6Ldi-KYUAAAAANoy8R5hUZ6_UqKfMZdzZjaKAdcJ', {action: 'email_subscribe'}).then( function(token){

                    var recaptchas = document.getElementsByClassName('recaptchav3_form');
                    for (var i = 0; i < recaptchas.length; ++i) {

                        var input = document.createElement("input");
                        input.setAttribute("type", "hidden");
                        input.setAttribute("name", "form[g-recaptcha-response]");
                        input.setAttribute("value", token);
                        recaptchas[i].appendChild(input);

                    }

                });
            });
        </script>
        <!-- ******* DEBUGGER : single.php ******* -->
      <meta name="onesignal" content="wordpress-plugin"/>
          <link rel="manifest"
            href="https://www.autoguide.com/blog/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id="/>
          <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>    <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.autoguide.com/blog");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'ac46145d-d7c5-4bad-8ea5-5b2635618686';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.autoguide.com/blog/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['promptOptions'] = { };
              oneSignal_options['autoRegister'] = false;
              OneSignal.showHttpPrompt();
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>

		<style type="text/css" id="wp-custom-css">
			div.featured-img-no-specs {
    height: auto !important;
}

/* Hide banner COTY page */

.head-coty > img {
    display: none !important;
}

/* END Hide banner COTY page */

/* 7-Aug-2019 */

.fmtc-widget-title {
  display: block;
}

/* 21-Aug-2019 */

span.fmtc-widget-title {
	height: 40px;
}

#content span.fmtc-widget-title {
	height: 40px;
}		</style>
	
<!-- ConsolidatedFooters Headers -->

<!-- GEOIP Header -->
<script type="text/javascript">
var vsCFIsEU = vsCFIsEU || null;
var vsCFUserGeoIP = vsCFUserGeoIP || null;
var vsCFTagsEUFunctions = vsCFTagsEUFunctions || [];
var vsCFTagsNonEuFunctions = vsCFTagsNonEuFunctions || [];
var vsCFCookieLimit = vsCFCookieLimit || 1; //1 day

function vsCFCreateCookie(name,value,days) {
	if (days) {
		var date = new Date();
		date.setTime(date.getTime()+(days*24*60*60*1000));
		var expires = "; expires="+date.toGMTString();
	}
	else var expires = "";

	document.cookie = name+"="+value+expires+"; path=/";
}
function vsCFReadCookie(name) {
	var nameEQ = name + "=";
	var ca = document.cookie.split(";");
	for(var i=0;i < ca.length;i++) {
		var c = ca[i];
		while (c.charAt(0)==" ") c = c.substring(1,c.length);
		if (c.indexOf(nameEQ) == 0) return c.substring(nameEQ.length,c.length);
	}
	return null;
}
 
//Execute ajax call to verify user EU GEOIP and start correct process.
function vsCFSendAjax() {
	xhttp = new XMLHttpRequest();
	xhttp.abort();
	xhttp.onreadystatechange = function () {
		if (xhttp.readyState == 4) { 
			if (xhttp.status == 200) {
				var jsonResponse = JSON.parse(xhttp.responseText);

				if (jsonResponse.status == true) {
					// if EU and execute eu tags
					vsCFIsEU = true;
					vsCFUserGeoIP = jsonResponse.geoip;
					vsCFExecuteEuTags();
				} else {
					// if Non EU and execute Non eu tags
					vsCFIsEU = false;
					vsCFUserGeoIP = jsonResponse.geoip;
					vsCFExecuteNonEuTags();
				}
				
				vsCFCreateCookie("vsCFIsEU", vsCFIsEU, vsCFCookieLimit);
				vsCFCreateCookie("vsCFUserGeoIP", vsCFUserGeoIP, vsCFCookieLimit);
			}
		}
	};
	xhttp.open("GET", "/videoplayer/verify_user_eu_geoip.php?verifyUserGeoIp=true");
	xhttp.setRequestHeader("X-Requested-With", "xmlhttprequest");
	xhttp.send(); 
}

function vsCFVerifyUserGeoIp(geoIps) {

	if (!vsCFUserGeoIP || !geoIps)
	 return true;
	
	if (!(geoIps instanceof Array)) {
		geoIps = geoIps.replace("__gt__" , "");
		geoIps = geoIps.split(',');
	}
        
	target = true;
	if (geoIps instanceof Array && geoIps[0] && geoIps[0] == "-") {
		target = false; // Exclusion is selected
		geoIps.shift();
	}
	
	geoIPCountryCode = vsCFUserGeoIP;
	
	if (!geoIPCountryCode)
		return ((target) ? false : true);
	
	return ((target) ? (geoIps.includes(geoIPCountryCode) ? true : false) : (geoIps.includes(geoIPCountryCode) ? false : true));
}

//Execute Eu Tags Function
function vsCFExecuteEuTags() {
	for (f of vsCFTagsEUFunctions) {
		f();
	}
	
	vsCFTagsEUFunctions = [];
}

//Execute None Eu Tags Function
function vsCFExecuteNonEuTags() {
	for (f of vsCFTagsNonEuFunctions) {
		f();
	} 

	vsCFTagsNonEuFunctions = [];
}
</script>
<!-- /GEOIP Header -->
<!-- Analytics -->
<script type="text/javascript">
  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-30657-132']);
  _gaq.push(['_setDomainName', '.autoguide.com']);
  _gaq.push(['_gat._anonymizeIp']);
  _gaq.push(['_trackPageview']);                _gaq.push(['_setCustomVar',5,'author','Kyle Patrick',3]);

                _gaq.push(['_setCustomVar',4,'postedDate','20200403',3]);

                _gaq.push(['_setCustomVar',3,'PageID','wp815926',3]);

                _gaq.push(['_setCustomVar',2,'postType','post',3]);
  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
</script>
<!-- /Analytics -->

<script>
window.googlefc = window.googlefc || {}; googlefc.callbackQueue = googlefc.callbackQueue || [];
</script><!-- Comscore -->
<script type="text/javascript">
function vsCFComscoreEU() {
	if (typeof googlefc == "object") {
		googlefc.callbackQueue.push(function() {
			if ( gfchelper.isAdProviderAllowed("comscore") ) {
				var _comscore = _comscore || [];
				_comscore.push({ c1: "2", c2: "6036030", c4: "autoguide.com" });
				(function() {
					var s = document.createElement("script"), el =
					document.getElementsByTagName("script")[0]; s.async = true;
					s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
					el.parentNode.insertBefore(s, el);
				})();
			}
		});
	} else { 
		console.log("cf: comscore googlefc not found.");
	}
}
function vsCFComscoreNonEU() {
	var _comscore = _comscore || [];
	_comscore.push({ c1: "2", c2: "6036030", c4: "autoguide.com" });
	(function() {
		var s = document.createElement("script"), el =
		document.getElementsByTagName("script")[0]; s.async = true;
		s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
		el.parentNode.insertBefore(s, el);
	})();
}

//Add comscore tag functions to eu and non-eu arrays.
vsCFTagsEUFunctions.push(vsCFComscoreEU);
vsCFTagsNonEuFunctions.push(vsCFComscoreNonEU);  
</script>
<!-- /Comscore -->
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start":
new Date().getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!="dataLayer"?"&l="+l:"";j.async=true;j.src=
"https://www.googletagmanager.com/gtm.js?id="+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,"script","dataLayer","GTM-M263JZ");</script>
<!-- End Google Tag Manager -->

<!-- /ConsolidatedFooters Headers --><script>window.deployads=window.deployads||[];wrapperSrc="//tags-cdn.deployads.com/a/vs.autoguide.com.js";(function(){var gads=document.createElement('script');gads.async=true;gads.type='text/javascript';var useSSL='https:'==document.location.protocol;gads.src=(useSSL?'https:':'http:')+wrapperSrc;var node=document.getElementsByTagName('script')[0];node.parentNode.insertBefore(gads,node);})();</script>
<script>
	var $ = jQuery.noConflict();
</script>
<!-- auto-news only? -->
<script src="//www.google.com/jsapi"></script>
<!-- for top10 -->
<script src="https://www.autoguide.com/blog/wp-content/themes/autoguide/jquery.prettyGallery.js?v=1554409983"></script>


<meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=yes, minimum-scale=1" />

<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@AutoGuide">

<link href="https://plus.google.com/109874395990076586660" rel="publisher" />


<!-- FB Open Graph --><!--  some added by Yoast -->
<meta property="fb:app_id" content="198414500205717" />
<!-- Schema +Snippet -->
<meta itemprop="name" content="How to Watch Every Racing Esport Event This Weekend">
<meta itemprop="image" content="https://www.autoguide.com/blog/wp-content/uploads/2020/04/Esports-Race-Weekend-2020-04-03-679x415.jpg">

<link rel="stylesheet" type="text/css" href="https://www.autoguide.com/blog/wp-content/themes/autoguide/css/auto-news-style.css?v=1536072107" media="screen" />
<link rel="alternate" type="application/rss+xml" title="AutoGuide.com News RSS Feed" href="//www.autoguide.com/auto-news/feed/" />



<!-- gpt sync -->
<script type="text/javascript">
(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
</script>


<script id='dfpsetup' type='text/javascript'>

var _vsDFPDebugInfo = '';

googletag.cmd.push(function() {

<!-- gpt -->
googletag.defineSlot('/1030735/AutoGuide_com_300x250_Top1_AUTO', [300, 250], 'AutoGuide_com_300x250_Top1_AUTO').
  defineSizeMapping(googletag.sizeMapping().addSize([1024, 10], [300, 250]).addSize([749, 10], [300, 250]).addSize([0, 0], [99999, 99999]).build()).
  addService(googletag.pubads());
<!-- gpt -->
googletag.defineSlot('/1030735/Autoguide_com_300x90_Spotlight_AUTO', [300, 90], 'Autoguide_com_300x90_Spotlight_AUTO').
  defineSizeMapping(googletag.sizeMapping().addSize([1024, 10], [300, 90]).addSize([749, 10], [300, 90]).addSize([0, 0], [99999, 99999]).build()).
  addService(googletag.pubads());
<!-- gpt -->
googletag.defineSlot('/1030735/AutoGuide_com_Compare_Sponsor_small_AUTO', [109, 19], 'AutoGuide_com_Compare_Sponsor_small_AUTO').
  defineSizeMapping(googletag.sizeMapping().addSize([1024, 10], [109, 19]).addSize([749, 10], [109, 19]).addSize([0, 0], [99999, 99999]).build()).
  addService(googletag.pubads());
<!-- gpt -->
googletag.defineSlot('/1030735/AutoGuide_com_300x250_Middle_AUTO', [300, 250], 'AutoGuide_com_300x250_Middle_AUTO').
  defineSizeMapping(googletag.sizeMapping().addSize([1024, 10], [300, 250]).addSize([749, 10], [300, 250]).addSize([0, 0], [99999, 99999]).build()).
  addService(googletag.pubads());
<!-- gpt -->
googletag.defineSlot('/1030735/AutoGuide_com_300x600_Right_AUTO', [  [300, 600], [300, 1050] ], 'AutoGuide_com_300x600_Right_AUTO').
  defineSizeMapping(googletag.sizeMapping().addSize([1024, 10], [  [300, 600], [300, 1050] ]).addSize([749, 10], [  [300, 600], [300, 1050] ]).addSize([0, 0], [99999, 99999]).build()).
  addService(googletag.pubads());
<!-- gpt -->
googletag.defineSlot('/1030735/AutoGuide_com_300x19_Sidebar1_AUTO', [300, 19], 'AutoGuide_com_300x19_Sidebar1_AUTO').
  defineSizeMapping(googletag.sizeMapping().addSize([1024, 10], [300, 19]).addSize([749, 10], [300, 19]).addSize([0, 0], [99999, 99999]).build()).
  addService(googletag.pubads());
<!-- gpt -->
googletag.defineSlot('/1030735/AutoGuide_com_x61_AUTO', [1658, 1000], 'AutoGuide_com_x61_AUTO').
  defineSizeMapping(googletag.sizeMapping().addSize([1024, 10], [1658, 1000]).addSize([0, 0], [99999, 99999]).build()).
  addService(googletag.pubads());
<!-- gpt -->
googletag.defineSlot('/1030735/AutoGuide_com_186x65_TopRight_AUTO', [186, 90], 'AutoGuide_com_186x65_TopRight_AUTO').
  defineSizeMapping(googletag.sizeMapping().addSize([1024, 10], [186, 90]).addSize([0, 0], [99999, 99999]).build()).
  addService(googletag.pubads());
<!-- gpt -->
googletag.defineSlot('/1030735/AutoGuide_com_728x90_Top_AUTO', [728, 90], 'AutoGuide_com_728x90_Top_AUTO').
  defineSizeMapping(googletag.sizeMapping().addSize([1024, 10], [728, 90]).addSize([749, 10], [728, 90]).addSize([0, 0], [99999, 99999]).build()).
  addService(googletag.pubads());
<!-- gpt -->
googletag.defineSlot('/1030735/AutoGuide_com_Position4_AUTO', [  [999, 90], [970, 250] ], 'AutoGuide_com_Position4_AUTO').
  defineSizeMapping(googletag.sizeMapping().addSize([1024, 10], [  [999, 90], [970, 250] ]).addSize([0, 0], [99999, 99999]).build()).
  addService(googletag.pubads());
<!-- gpt -->
googletag.defineSlot('/1030735/AutoGuide_com_1x1_Bottom_AUTO', [1, 1], 'AutoGuide_com_1x1_Bottom_AUTO').
  addService(googletag.pubads());
<!-- gpt -->
googletag.defineSlot('/1030735/Autoguide_com_300x250_Mobile_Bottom_AUTO', [300, 250], 'Autoguide_com_300x250_Mobile_Bottom_AUTO').
  defineSizeMapping(googletag.sizeMapping().addSize([1024, 10], [99999, 99999]).addSize([749, 10], [99999, 99999]).addSize([0, 0], [300, 250]).build()).
  addService(googletag.pubads());
<!-- gpt -->
googletag.defineSlot('/1030735/Autoguide_com_320x50_Mobile_Bottom_AUTO', [320, 50], 'Autoguide_com_320x50_Mobile_Bottom_AUTO').
  defineSizeMapping(googletag.sizeMapping().addSize([1024, 10], [99999, 99999]).addSize([749, 10], [99999, 99999]).addSize([0, 0], [320, 50]).build()).
  addService(googletag.pubads());

googletag.defineSlot('/1030735/AutoGuide_com_1x1_Slimcut_AUTO_Content', [1, 1], 'AutoGuide_com_1x1_Slimcut_AUTO_Content').addService(googletag.pubads());


googletag.pubads().setTargeting("PageID", "wp815926");
googletag.pubads().setTargeting("section1", "auto-news");
googletag.pubads().setTargeting("sitename", "autoguide_com");
googletag.pubads().setTargeting("folder1", "auto-news");
googletag.pubads().setTargeting("folder2", "2020");
googletag.pubads().setTargeting("folder3", "04");
googletag.pubads().setTargeting("filename", "how-to-watch-every-racing-esport-event-t");



googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
deployads.push(function () { deployads.gpt.enableServices() });

});

</script>
<!-- /DFP TAG -->
    <script type="text/javascript">
        $(document).ready(function(){
            var width = window.innerWidth || document.documentElement.clientWidth;
            if ( width >= 750) {
                var script = document.createElement('script');
                script.src = "//services.cdn.speedshiftmedia.com/tags/tag-H20140604113419ee4bc43502198.min.js" ;
                document.getElementsByTagName('head')[0].appendChild(script);
            }
        });
    </script>

<link rel="stylesheet" type="text/css" href="https://www.autoguide.com/blog/wp-content/themes/autoguide/scripts/galleria/themes/classic/galleria.classic.css"></script>
<script src="https://www.autoguide.com/blog/wp-content/themes/autoguide/scripts/galleria/galleria-1.4.2.min.js"></script>
<script src="https://www.autoguide.com/blog/wp-content/themes/autoguide/scripts/galleria/themes/classic/galleria.classic.min.js"></script>

			
<!-- Taboola Header -->
<script type="text/javascript">
function vsCFTaboolaHeaderEU() {
	if (typeof googlefc == "object") {
			googlefc.callbackQueue.push(function() {
				if ( gfchelper.isAdProviderAllowed("taboola") ) {
					window._taboola = window._taboola || [];
					_taboola.push({article:'auto'});
					!function (e, f, u) {
						e.async = 1;
						e.src = u;
						f.parentNode.insertBefore(e, f);
					}(document.createElement('script'), document.getElementsByTagName('script')[0], '//cdn.taboola.com/libtrc/verticalscope-network/loader.js');
				}
			});
	} else {
		console.log("cf: taboola googlefc not found.");
	}
}
function vsCFTaboolaHeaderNonEU() {
    window._taboola = window._taboola || [];
	_taboola.push({article:'auto'});
	!function (e, f, u) {
		e.async = 1;
		e.src = u;
		f.parentNode.insertBefore(e, f);
	}(document.createElement('script'), document.getElementsByTagName('script')[0], '//cdn.taboola.com/libtrc/verticalscope-network/loader.js');
}
//Add Taboola Header tag functions to eu and non-eu arrays.
vsCFTagsEUFunctions.push(vsCFTaboolaHeaderEU);
vsCFTagsNonEuFunctions.push(vsCFTaboolaHeaderNonEU);
</script>
<!-- /Taboola Header-->
	<script defer src="https://static.verticalscope.com/vs_iframe-messenger/vs-iframe-messenger-v2.js"></script>
</head>

<body class="post-template-default single single-post postid-815926 single-format-standard">

<!-- ConsolidatedFooters Body Top w/o buffer -->

<script src="https://contributor.google.com/scripts/5e763cfe1b429dfd/loader.js"></script><script>window.googlefc = window.googlefc || {}; googlefc.callbackQueue = googlefc.callbackQueue || [];</script><script src="https://fundingchoices.google.com/f/AGSKWxWU-J4z37MRts2tjjLYAZbmNxzDm5E4Ym2j6ppGE6yTN_fbYq9I5Dk5RoXNqmp5j4_d-Y1crhw="></script><iframe name="googlefcPresent" style="display: none; width: 0px; height: 0px; border: none; z-index: -1000; left: -1000px; top: -1000px;"></iframe>
<script>
/* Custom FC functions here */
var gfchelper = window.gfchelper || {
	adProviders: {"appnexus":"80","comscore":"62","dfp":"229","indexexchange":"126","liveramp":"12","openx":"363","rubicon":"1029","sovrn":"2706","taboola":"86","viglink":"fc-company-5e763cfe1b429dfd-23f5ef4587d0c639","captify":"fc-company-5e763cfe1b429dfd-70e99e6af140599f"},
	isAdProviderAllowed: function( providerName ) {
		if(
			!providerName
			|| typeof googlefc === "undefined"
			|| typeof googlefc.getConsentedProviderIds === "undefined"
			//|| googleprivacySettings.trackUserOk === false
		) {
			return false;
		}
		// get google FC Consented provider Ids for the current site
		let consentedIds = googlefc.getConsentedProviderIds() || [];
		// Allow only those we want and are allowed
		return !!consentedIds.find( p => gfchelper.adProviders[ providerName.toLowerCase() ] && p === gfchelper.adProviders[ providerName.toLowerCase() ] );
	}
};
googlefc.callbackQueue.push(function () {
    dataLayer = window.dataLayer || [];
    switch (googlefc.getConsentStatus()) {
        case googlefc.ConsentStatusEnum.CONSENTED_TO_PERSONALIZED_ADS:
        case googlefc.ConsentStatusEnum.CONSENT_NOT_REQUIRED:
            dataLayer.push({
                "event": "event_fcconsent"
            });
            break;
        default:
            dataLayer.push({
                "event": "event_fcconsent_denied"
            });
            break;
    }
});
</script>

<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M263JZ"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

<!-- /ConsolidatedFooters Body Top w/o buffer -->

<!-- AutoGuide_com_x61_AUTO wallpaper -->
<div id="bgSyncBlock" style="display:none;">
<div id='AutoGuide_com_x61_AUTO' class="ad vsHPTO-iframe" >
<script type='text/javascript'>
googletag.cmd.push(function() { deployads.push(function() {deployads.gpt.display('AutoGuide_com_x61_AUTO'); }); });
</script>
</div>
</div>

<div id="container">


<!--  header part begin -->

<!-- Facebook SDK -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.8&appId=198414500205717";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<!-- End Facebook SDK -->

<!-- header starts -->
<header id="header" class="vsadspot noprint" >

	<!-- vs summit begin -->
    <section class="text_wrapper" id="header-features">

       <ul>

            <li>
                <a class="photo" href="https://www.autoguide.com/top-10-best-xbox-one-racing-games"><img src="https://www.autoguide.com/blog/wp-content/uploads/2020/03/top-10-best-xbox-one-racing-games-186x114.jpg" width="186" height="65" alt="Top 10 Best Xbox One Racing Games"></a>
                <h3><a href="https://www.autoguide.com/top-10-best-xbox-one-racing-games">Best Xbox One Racing Games</a></h3>
            </li>
            <li>
                <a class="photo" href="https://www.autoguide.com/gmc/acadia"><img src="https://www.autoguide.com/blog/wp-content/uploads/2020/03/2020-GMC-Acadia-Denali-001-186x118.jpg" width="186" height="65" alt="GMC Acadia – Review, Specs, Pricing, Features, Videos and More"></a>
                <h3><a href="https://www.autoguide.com/gmc/acadia">GMC Acadia, All You Should Know</a></h3>
            </li>
            <li>
                <a class="photo" href="https://www.autoguide.com/toyota/sienna"><img src="https://www.autoguide.com/blog/wp-content/uploads/2020/01/2020-Toyota-Sienna-SE-Review-13-186x116.jpg" width="186" height="65" alt="Toyota Sienna – Review, Specs, Pricing, Features, Videos and More"></a>
                <h3><a href="https://www.autoguide.com/toyota/sienna">Toyota Sienna 101</a></h3>
            </li>
            <li>
                <a class="photo" href="https://www.autoguide.com/top-5-best-monitors-for-racing-games"><img src="https://www.autoguide.com/blog/wp-content/uploads/2020/03/top-5-best-monitors-for-racing-games-186x114.jpg" width="186" height="65" alt="Top 5 Best Monitors for Racing Games"></a>
                <h3><a href="https://www.autoguide.com/top-5-best-monitors-for-racing-games">Best Monitors for Racing Games</a></h3>
            </li>
			<li>
				<div class="ad" id="AutoGuide_com_186x65_TopRight_AUTO" >
				<script type='text/javascript'>
				googletag.cmd.push(function() { deployads.push(function() {deployads.gpt.display('AutoGuide_com_186x65_TopRight_AUTO'); }); });
				</script>
				</div>
            </li>

        </ul>
    </section>
    <!-- vs summit end -->


    <div class="text_wrapper logo_wrapper">

<!-- AutoGuide_com_728x90_Top_AUTO -->
<div id='AutoGuide_com_728x90_Top_AUTO' class="ad" >
<script type='text/javascript'>
googletag.cmd.push(function() { deployads.push(function() {deployads.gpt.display('AutoGuide_com_728x90_Top_AUTO'); }); });
</script>
</div>

		<span class="nav-wrapper-icon icon"><!-- -->&nbsp;</span>

		<!-- MOVED LOGO -->
        <a href="/index.html" id="logo"><img src="/img/logo.png" alt="AutoGuide.com" width="250" height="56"></a>

    </div>

	<!-- ADDED NAV WRAPPER-->
	<section class="nav-wrapper">

    	<nav id="nav" class="nav">
        <ul id="main-nav">
<li class="hover" ><a href="/auto-news/">Auto News</a><div id="auto-news-nav" class="">
			<div class="menu-rollover-sub"><ul><li id="menu-item-717324" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-717324"><a href="https://www.autoguide.com/auto-news/category/spy-photos">Spy Photos</a></li>
<li id="menu-item-717326" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-717326"><a href="https://www.autoguide.com/auto-news/category/top-10">Top 10</a></li>
<li id="menu-item-717328" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-717328"><a href="/auto-shows/">Auto Shows</a></li>
</ul></div>
			</div>
</li>
<li class="hover" ><a href="/new-cars/">New Cars</a><div id="manufacturers-nav" class="">
			<div class="menu-rollover-sub"><ul><li id="menu-item-741810" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-741810"><a href="https://www.autoguide.com/new-cars/compare.html">Car Comparisons</a></li>
<li id="menu-item-717312" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-717312"><a href="/buyers-guide">Buyer&#8217;s Guides</a></li>
<li id="menu-item-741808" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-741808"><a href="https://www.autoguide.com/future-cars">Future Cars</a></li>
<li id="menu-item-717310" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-717310"><a href="/buyers-guide/auto-insurance.html">Auto insurance</a></li>
</ul></div>
			<div class="list manufacturers-list"><ul><li id="menu-item-263339" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263339"><a href="/new-cars/acura/index.html">Acura</a></li>
<li id="menu-item-440676" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-440676"><a href="/new-cars/alfa-romeo/index.html">Alfa Romeo</a></li>
<li id="menu-item-263340" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263340"><a href="/new-cars/aston-martin/index.html">Aston Martin</a></li>
<li id="menu-item-263341" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263341"><a href="/new-cars/audi/index.html">Audi</a></li>
<li id="menu-item-263342" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263342"><a href="/new-cars/bentley/index.html">Bentley</a></li>
<li id="menu-item-263343" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263343"><a href="/new-cars/bmw/index.html">BMW</a></li>
<li id="menu-item-263344" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263344"><a href="/new-cars/buick/index.html">Buick</a></li>
<li id="menu-item-263345" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263345"><a href="/new-cars/cadillac/index.html">Cadillac</a></li>
<li id="menu-item-263346" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263346"><a href="/new-cars/chevrolet/index.html">Chevrolet</a></li>
<li id="menu-item-263347" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263347"><a href="/new-cars/chrysler/index.html">Chrysler</a></li>
<li id="menu-item-263348" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263348"><a href="/new-cars/dodge/index.html">Dodge</a></li>
<li id="menu-item-451012" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-451012"><a href="/new-cars/faraday-future/index.html">Faraday Future</a></li>
<li id="menu-item-263349" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263349"><a href="/new-cars/ferrari/index.html">Ferrari</a></li>
<li id="menu-item-263350" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263350"><a href="/new-cars/fiat/index.html">Fiat</a></li>
<li id="menu-item-263351" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263351"><a href="/new-cars/ford/index.html">Ford</a></li>
<li id="menu-item-440677" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-440677"><a href="/new-cars/genesis/index.html">Genesis</a></li>
<li id="menu-item-263352" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263352"><a href="/new-cars/gmc/index.html">GMC</a></li>
<li id="menu-item-263353" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263353"><a href="/new-cars/honda/index.html">Honda</a></li>
<li id="menu-item-263354" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263354"><a href="/new-cars/hyundai/index.html">Hyundai</a></li>
<li id="menu-item-263355" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263355"><a href="/new-cars/infiniti/index.html">Infiniti</a></li>
<li id="menu-item-263356" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263356"><a href="/new-cars/jaguar/index.html">Jaguar</a></li>
<li id="menu-item-263357" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263357"><a href="/new-cars/jeep/index.html">Jeep</a></li>
<li id="menu-item-263358" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263358"><a href="/new-cars/kia/index.html">Kia</a></li>
<li id="menu-item-263359" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263359"><a href="/new-cars/lamborghini/index.html">Lamborghini</a></li>
<li id="menu-item-263360" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263360"><a href="/new-cars/land-rover/index.html">Land Rover</a></li>
<li id="menu-item-263361" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263361"><a href="/new-cars/lexus/index.html">Lexus</a></li>
<li id="menu-item-263362" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263362"><a href="/new-cars/lincoln/index.html">Lincoln</a></li>
<li id="menu-item-263363" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263363"><a href="/new-cars/lotus/index.html">Lotus</a></li>
<li id="menu-item-451009" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-451009"><a href="/new-cars/lucid-motors/index.html">Lucid Motors</a></li>
<li id="menu-item-263364" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263364"><a href="/new-cars/maserati/index.html">Maserati</a></li>
<li id="menu-item-263365" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263365"><a href="/new-cars/mazda/index.html">Mazda</a></li>
<li id="menu-item-263376" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263376"><a href="/new-cars/mclaren/index.html">McLaren</a></li>
<li id="menu-item-263366" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263366"><a href="/new-cars/mercedes-benz/index.html">Mercedes-Benz</a></li>
<li id="menu-item-263367" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263367"><a href="/new-cars/mini/index.html">Mini</a></li>
<li id="menu-item-263368" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263368"><a href="/new-cars/mitsubishi/index.html">Mitsubishi</a></li>
<li id="menu-item-263369" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263369"><a href="/new-cars/nissan/index.html">Nissan</a></li>
<li id="menu-item-451010" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-451010"><a href="/new-cars/pagani/index.html">Pagani</a></li>
<li id="menu-item-263370" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263370"><a href="/new-cars/porsche/index.html">Porsche</a></li>
<li id="menu-item-263371" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263371"><a href="/new-cars/ram/index.html">Ram</a></li>
<li id="menu-item-762874" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-762874"><a href="/new-cars/rivian/index.html">Rivian</a></li>
<li id="menu-item-263372" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263372"><a href="/new-cars/rolls-royce/index.html">Rolls-Royce</a></li>
<li id="menu-item-263374" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263374"><a href="/new-cars/smart/index.html">Smart</a></li>
<li id="menu-item-263375" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263375"><a href="/new-cars/subaru/index.html">Subaru</a></li>
<li id="menu-item-263377" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263377"><a href="/new-cars/tesla/index.html">Tesla</a></li>
<li id="menu-item-263378" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263378"><a href="/new-cars/toyota/index.html">Toyota</a></li>
<li id="menu-item-263379" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263379"><a href="/new-cars/volkswagen/index.html">Volkswagen</a></li>
<li id="menu-item-263380" class="custom menu-item menu-item-type-custom menu-item-object-custom menu-item-263380"><a href="/new-cars/volvo/index.html">Volvo</a></li>
</ul></div></div>
</li>
<li><a href="/used-cars/">Used Cars</a></li>
<li><a href="/manufacturer/car-reviews.html">Car Reviews</a></li>
<li class="hover" ><a href="/tips-and-advice/">Auto Resources</a><div id="tips-nav" class="">
			<div class="menu-rollover-sub"><ul><li id="menu-item-717322" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-717322"><a href="/auto-news/tag/how-to">How Tos</a></li>
<li id="menu-item-717454" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-717454"><a href="/car-loans">Car Loan</a></li>
<li id="menu-item-717456" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-717456"><a href="/buyers-guide/auto-insurance.html">Auto Insurance</a></li>
<li id="menu-item-813118" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-813118"><a href="https://www.autoguide.com/auto-glass-repair/">Auto Glass Repair</a></li>
</ul></div>
			</div>
</li>
<li><a href="/videos.html">Video</a></li>
		</ul>
		<ul class="nav-social">
			<li><a href="https://www.facebook.com/AutoGuide" rel="nofollow" target="_blank"><img src="https://www.autoguide.com/blog/wp-content/themes/autoguide/images/nav-facebook.png" alt="Facebook" title="Facebook" /></a></li>
			<li><a href="https://twitter.com/AutoGuide" rel="nofollow"  target="_blank" ><img src="https://www.autoguide.com/blog/wp-content/themes/autoguide/images/nav-twitter.png" alt="Twitter" title="Twitter" /></a></li>
			<li><a href="https://www.youtube.com/AutoGuide" rel="nofollow" target="_blank" ><img src="https://www.autoguide.com/blog/wp-content/themes/autoguide/images/nav-youtube.png" alt="Youtube" title="Youtube" /></a></li>
			<li><a href="https://www.autoguide.com/latest-articles.xml" rel="nofollow" target="_blank"><img src="https://www.autoguide.com/blog/wp-content/themes/autoguide/images/nav-rss.png" alt="RSS" title="RSS"  /></a></li>
		</ul>
    	</nav>

<!-- OLD SEARCH CODE -->
    	<nav class="subnav" id="subnav">

        <ul>

<li><a href="/parts-accessories">Parts &#038; Accessories</a></li>
<li><a href="/tires-wheels">Tires &#038; Wheels</a></li>
<li><a href="/car-care">Car Care</a></li>
<li><a href="/tools-equipment">Tools &#038; Equipment</a></li>
<li><a href="/electronics">Electronics</a></li>
<li><a href="/deals-gifts">Deals &#038; Gift Ideas</a></li>
        </ul>
        </nav>
    </section>
	<!-- END NAV WRAPPER-->

	<!-- ADDED SEARCH-WRAPPER AND MOVED SEARCH CODE -->
	<section class="search-wrapper">
        <span class="search-link open-search icon"><!-- -->&nbsp;</span>
        <form id="google-cse-searchbox-form" action="/search.html" style="display:none">
		    <input type="text" onFocus="if(this.value=='Search AutoGuide.com') this.value=''" value="Search AutoGuide.com" name="q">
            <input type="submit" value="Search" >
            <span class="search-link button close"><img alt="close" src="https://www.autoguide.com/blog/wp-content/themes/autoguide/images/X.png" /></span>
        </form>
	</section>
	<!-- END SEARCH-WRAPPER AND MOVED SEARCH CODE -->



</header>
<!-- header ends -->

<!-- header from cache --><!--  header part end -->

<div id="content" class="text_wrapper">

<!-- AutoGuide_com_Position4_AUTO -->
<div id='AutoGuide_com_Position4_AUTO' class="vsPUSHDOWN-iframe" >
<script type='text/javascript'>
googletag.cmd.push(function() { deployads.push(function() {deployads.gpt.display('AutoGuide_com_Position4_AUTO'); }); });
</script>
</div>


<div id="main-content_wrapper">
<div id="main-content">

<!-- body starts -->


<div class="vsadspot inner-pages article-page news">
<div class="breadcrumb">
    <a href="/auto-news/" >Auto News</a> <span>How to Watch Every Racing Esport Event This Weekend</span>
</div>
<div id="promo_area">
<div class="text_wrapper pretitle-nav hide-mobile">
		<a class="prev" href="https://www.autoguide.com/auto-news/2020/04/join-us-in-another-forza-friday-livestream-on-april-3.html" title="previous post: Join Us in Another Forza Friday Livestream April 3">Join Us in Another Forza Friday...</a></div>
</div>
<!-- end promo_area -->

<div id="body_content">

<section class="text_wrapper section feature main-feature">
	<article itemtype="http://schema.org/Article" itemscope="" class="text_wrapper article thumbnails thumbnails-large">
	<div style="display:none" itemtype="https://schema.org/Organization" itemscope="itemscope" itemprop="publisher"> 
			<link itemprop="url" href="https://www.autoguide.com/"> 
			<span itemprop="name">AutoGuide.com</span> 
			<span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.autoguide.com/img/logo.png"><meta itemprop="width" content="250"><meta itemprop="height" content="56"></span> 
		</div> 
		<header id="title-area">
		
			<h1 class="title" itemprop="headline">How to Watch Every Racing Esport Event This Weekend</h1>
					</header>
		<!-- title-area -->

		

<!-- Article Social block under header -->
<div class="social-block">
    <div class="row collapse">
        <div class="small-6 medium-4 columns s-facebook"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.autoguide.com%2Fauto-news%2F2020%2F04%2Fhow-to-watch-every-racing-esport-event-this-weekend.html" class="social-link" onclick="window.open(this.href, '', 'height=279,width=575'); return false;"><span class="f">Share</span><span class="count" data-facebook-share-count-url="https://www.autoguide.com/auto-news/2020/04/how-to-watch-every-racing-esport-event-this-weekend.html"></span></a></div>
        <div class="small-6 medium-4 columns s-twitter"><a href="https://twitter.com/intent/tweet?text=How+to+Watch+Every+Racing+Esport+Event+This+Weekend&amp;url=https%3A%2F%2Fwww.autoguide.com%2Fauto-news%2F2020%2F04%2Fhow-to-watch-every-racing-esport-event-this-weekend.html&amp;via=autoguide" class="social-link" onclick="window.open(this.href, '', 'height=430,width=600'); return false;"><span class="t">Tweet</span><span class="count" data-twitter-share-count-url="https://www.autoguide.com/auto-news/2020/04/how-to-watch-every-racing-esport-event-this-weekend.html"></span></a></div>
        <div class="small-12 medium-4 columns s-subscribe"><a href="" class="social-link" style="">Subscribe<span class="arrow"></span></a></div>
    </div>
    <div class="row subscribe-sub">
        <div class="small-12 medium-6 columns">
            <h4>Get AutoGuide.com in your Inbox</h4>
		<form action="//email.autoguide.com/newsletter-signup/" method="post" class="recaptchav3_form newslettersignup-form">
		<input type="hidden" name="form[source]" value="wp_generic" />
		<input type="text" placeholder="Your Email Address" name="form[email]" required />
        		<input type="hidden" name="form[subscribeCheck]" required="required" value="1" />
                <input type="submit" class="button radius" value="Sign-up">
			</form>
			<div class='vs-recaptcha-notification'>
				This site is protected by reCAPTCHA and the Google
				<a href="https://policies.google.com/privacy">Privacy Policy</a> and
				<a href="https://policies.google.com/terms">Terms of Service</a> apply.
		 	 </div>
        </div>
        <div class="small-12 medium-6 columns">
            <h4>Like AutoGuide.com on Facebook</h4>
            <div class="fb-like" data-href="https://www.facebook.com/AutoGuide" data-layout="button_count" data-action="like" data-show-faces="true" data-share="false"></div>
        </div>
    </div>
</div>
<!-- Article Social block under header -->


	    <div class="text_wrapper comments-wrapper">

			
	        <div class="byline">

	        <span itemprop="author" class="author">By <a href="https://www.autoguide.com/author/kyle-patrick.html" title="Posts by Kyle Patrick" rel="author">Kyle Patrick</a></span>
	        <span class="date"><meta itemprop="datePublished" content="2020-04-03">Apr 03, 2020</span>
	        	        </div>

			<span class="comments">
	        		<a href="https://www.autoguide.com/auto-news/2020/04/how-to-watch-every-racing-esport-event-this-weekend.html#respond"><span class="dsq-postid" data-dsqidentifier="815926 https://www.autoguide.com/?p=815926"></span></a>			</span>

	    </div>

			<div class="picture main-column-fixed">
			<a href="https://www.autoguide.com/auto-news/2020/04/how-to-watch-every-racing-esport-event-this-weekend.html"><img class="photo" src="/img/spacer.gif" data-original="https://www.autoguide.com/blog/wp-content/uploads/2020/04/Esports-Race-Weekend-2020-04-03-679x415.jpg" alt="How to Watch Every Racing Esport Event This Weekend"></a>
			<meta itemprop="image" content="https://www.autoguide.com/blog/wp-content/uploads/2020/04/Esports-Race-Weekend-2020-04-03-679x415.jpg">
	    </div>
		

    <div class="text_wrapper article-blurb">

<p></p> <p><strong>Real world racing may be on hold due to COVID-19, but the digital side is showing no sign of slowing down.</strong></p> <p><span id="more-815926"></span></p> <p>As the major racing series cancel or postpone much of their calendar, they&#8217;re increasingly turning to sim racing to keep the viewers—and drivers—engaged. The move has thrust sim racing into the mainstream spotlight, leading to record viewership numbers. Having the real-world pros fighting it out on track against each other, as well as established sim racing experts, has been a welcome bit of fun in these uncertain times. A lighter mood is something we can all appreciate, right?</p> <p>The digital revolution comes with its own packed weekend schedule. So we&#8217;ve rounded up the main events for this weekend and listed the important details here.</p> <h2>Formula 1</h2> <p>F1 is running Virtual Grands Prix in place of the real deal. This weekend was meant to be the first held in Hanoi, Vietnam&#8217;s capital. With that out of the picture—and not available in the current <em>F1 2019</em> title—the digital circus is instead heading to Albert Park, home of the Australian Grand Prix. Five current F1 drivers will take part, including Alex Albon, Nicholas Latifi, Charles Leclerc, Lando Norris and George Russell.</p> <p><strong>When and Where:</strong> The action takes place on the traditional Sunday, April 5. All of the drivers will be competing remotely, with a commentating team live from the Gfinity Esports Arena in the UK. The show begins at 19:00 UTC, and will be available at <a href="https://www.formula1.com/">F1.com</a> in addition to the official F1 <a href="https://www.youtube.com/channel/UCB_qr75-ydFVKSF9Dmo6izg">YouTube</a>, <a href="https://www.twitch.tv/formula1">Twitch</a> and <a href="https://www.facebook.com/Formula1/">Facebook</a> pages.</p> <h2>NASCAR</h2> <p>America&#8217;s motorsport has taken the lead in these digital times, being first to broadcast on a major network. It will continue with this week&#8217;s eNASCAR iRacing Pro Invitational Series, which heads to Bristol Motor Speedway. Drivers will come from the many NASCAR feeder series, including the Xfinity Series, truck series, ARCA and the Mexico series.</p> <p><strong>When and Where:</strong> The main event, the Food City Showdown, starts at 13:00 EST on Sunday, April 5. NASCAR is also bolstering the weekend with a new &#8220;Saturday Night Thunder&#8221; event the day before. You can check out Saturday&#8217;s racing online at <a href="http://www.enascar.com/">enascar.com</a>, while Sunday&#8217;s race will be available on Fox, FS1 and the Fox Sports App.</p> <h2>IndyCar</h2> <p>The other big open-wheel race series will run its second virtual event this weekend. Most of the current driver grid will take part, including the most successful driver: Scott Dixon. Last week&#8217;s winner, Sage Karam, will need to fight off Dixon, Josef Newgarden, and a total of 28 other drivers.</p> <p><strong>When and Where:</strong> IndyCar action gets underway Saturday, April 4 at 14:30 EST. Catch the action on NBC Sports Network, complete with the broadcasting team of Leigh Diffey, Townsend Bell and Paul Tracy.</p>
<!-- top10 only -->



		<div class="category-tags hide-mobile">

			Filed under: <span itemprop="keywords"><a href="https://www.autoguide.com/auto-news/category/featured-articles" rel="category tag">Featured Articles</a> <a href="https://www.autoguide.com/auto-news/category/motorsports/formula-1" rel="category tag">Formula 1</a> <a href="https://www.autoguide.com/auto-news/category/motorsports/indycar-motorsports" rel="category tag">IndyCar</a> <a href="https://www.autoguide.com/auto-news/category/motorsports/nascar" rel="category tag">NASCAR</a><br />
			Tags: <a href="https://www.autoguide.com/auto-news/tag/esports" rel="tag">Esports</a>, <a href="https://www.autoguide.com/auto-news/tag/iracing" rel="tag">iracing</a></span>

		</div>

	</div>

	</article>


</section>
<!-- end text_wrapper section feature -->



<!-- Article Social block under header -->
<div class="social-block">
    <div class="row collapse">
        <div class="small-6 medium-4 columns s-facebook"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.autoguide.com%2Fauto-news%2F2020%2F04%2Fhow-to-watch-every-racing-esport-event-this-weekend.html" class="social-link" onclick="window.open(this.href, '', 'height=279,width=575'); return false;"><span class="f">Share</span><span class="count" data-facebook-share-count-url="https://www.autoguide.com/auto-news/2020/04/how-to-watch-every-racing-esport-event-this-weekend.html"></span></a></div>
        <div class="small-6 medium-4 columns s-twitter"><a href="https://twitter.com/intent/tweet?text=How+to+Watch+Every+Racing+Esport+Event+This+Weekend&amp;url=https%3A%2F%2Fwww.autoguide.com%2Fauto-news%2F2020%2F04%2Fhow-to-watch-every-racing-esport-event-this-weekend.html&amp;via=autoguide" class="social-link" onclick="window.open(this.href, '', 'height=430,width=600'); return false;"><span class="t">Tweet</span><span class="count" data-twitter-share-count-url="https://www.autoguide.com/auto-news/2020/04/how-to-watch-every-racing-esport-event-this-weekend.html"></span></a></div>
        <div class="small-12 medium-4 columns s-subscribe"><a href="" class="social-link" style="">Subscribe<span class="arrow"></span></a></div>
    </div>
    <div class="row subscribe-sub">
        <div class="small-12 medium-6 columns">
            <h4>Get AutoGuide.com in your Inbox</h4>
		<form action="//email.autoguide.com/newsletter-signup/" method="post" class="recaptchav3_form newslettersignup-form">
		<input type="hidden" name="form[source]" value="wp_generic" />
		<input type="text" placeholder="Your Email Address" name="form[email]" required />
        		<input type="hidden" name="form[subscribeCheck]" required="required" value="1" />
                <input type="submit" class="button radius" value="Sign-up">
			</form>
			<div class='vs-recaptcha-notification'>
				This site is protected by reCAPTCHA and the Google
				<a href="https://policies.google.com/privacy">Privacy Policy</a> and
				<a href="https://policies.google.com/terms">Terms of Service</a> apply.
		 	 </div>
        </div>
        <div class="small-12 medium-6 columns">
            <h4>Like AutoGuide.com on Facebook</h4>
            <div class="fb-like" data-href="https://www.facebook.com/AutoGuide" data-layout="button_count" data-action="like" data-show-faces="true" data-share="false"></div>
        </div>
    </div>
</div>
<!-- Article Social block under header -->


<section class="latest-articles" id="related-reading">
<h2>More Auto News...</h2>


<!-- Taboola Mid Content -->
<div id="taboola-mid-article-stream-thumbnails"></div>
<script type="text/javascript">
function vsCFTaboolaMidContentEU() {
	if (typeof googlefc == "object") {
		googlefc.callbackQueue.push(function() {
			if ( gfchelper.isAdProviderAllowed("taboola") ) {
				window._taboola = window._taboola || [];
				_taboola.push({
						mode: 'organic-thumbnails-a',
						container: 'taboola-mid-article-stream-thumbnails',
						placement: 'Mid Article Stream Thumbnails - Auto',
						target_type: 'mix'
				});
			}
		});
	} else {
		console.log("cf: taboola googlefc not found.");
	}
}
function vsCFTaboolaMidContentNonEU() {
    window._taboola = window._taboola || [];
        _taboola.push({
                mode: 'organic-thumbnails-a',
                container: 'taboola-mid-article-stream-thumbnails',
                placement: 'Mid Article Stream Thumbnails - Auto',
                target_type: 'mix'
        });
}
//Add Taboola Content tag functions to eu and non-eu arrays.
vsCFTagsEUFunctions.push(vsCFTaboolaMidContentEU);
vsCFTagsNonEuFunctions.push(vsCFTaboolaMidContentNonEU);
</script>
<!-- /Taboola Mid Content-->

</section>
<!-- end related-reading -->


<!-- Taboola Content -->
<div id="taboola-below-article-thumbnails---3"></div>
<script type="text/javascript">
function vsCFTaboolaContentEU() {
	if (typeof googlefc == "object") {
			googlefc.callbackQueue.push(function() {
				if ( gfchelper.isAdProviderAllowed("taboola") ) {
					window._taboola = window._taboola || [];
					_taboola.push({
						mode: 'thumbnails-c',
						container: 'taboola-below-article-thumbnails---3',
						placement: 'Below Article Thumbnails 2nd',
						target_type: 'mix'
					});
				}
			});
	} else {
		console.log("cf: taboola googlefc not found.");
	}
}
function vsCFTaboolaContentNonEU() {
    window._taboola = window._taboola || [];
	_taboola.push({
		mode: 'thumbnails-c',
		container: 'taboola-below-article-thumbnails---3',
		placement: 'Below Article Thumbnails 2nd',
		target_type: 'mix'
	});
}
//Add Taboola Content tag functions to eu and non-eu arrays.
vsCFTagsEUFunctions.push(vsCFTaboolaContentEU);
vsCFTagsNonEuFunctions.push(vsCFTaboolaContentNonEU);
</script>
<!-- /Taboola Content-->

	<a name="respond"></a><a name="comments"></a>
	
<div id="disqus_thread"></div>


	<div id="AutoGuide_com_1x1_Slimcut_AUTO_Content" style="width: auto; height: auto;"><script type="text/javascript">googletag.cmd.push(function() { deployads.push(function() {deployads.gpt.display('AutoGuide_com_1x1_Slimcut_AUTO_Content'); }); });</script></div>

</div>
<!-- end body_content -->

</div>
<!-- end vsadspot inner-pages reviews -->



<!-- body ends -->

</div>
</div>
<!-- end main-content -->


<!-- right nav starts -->
<aside id="sidebar" class="noprint" >

<div class="sidebar-controls">
	<span class="sprite inlineimg sidebar-controls-icon"></span>
</div>
<!-- End sidebar-controls -->

<div class="sidebar noprint">

<section class="section noprint" id="contact-us">
	Know something we don't?<br />
	<a href="/contact-tips.html" class="title">Send us your Tips!</a>
</section><div class="ad" id="AutoGuide_com_300x250_Top1_AUTO">
<script type="text/javascript">
googletag.cmd.push(function() { deployads.push(function() {deployads.gpt.display('AutoGuide_com_300x250_Top1_AUTO'); }); });
</script>
</div>
<div class="ad" id="Autoguide_com_300x90_Spotlight_AUTO">
<script type="text/javascript">
googletag.cmd.push(function() { deployads.push(function() {deployads.gpt.display('Autoguide_com_300x90_Spotlight_AUTO'); }); });
</script>
</div>

<!-- New Social block sidebar under Spotlight -->
<div class="social-sidebar">
	<a href="https://www.facebook.com/AutoGuide" target="_blank" class="ss-f"><span>Like us on Facebook</span></a>
	<a href="https://twitter.com/intent/follow?screen_name=AutoGuide" onclick="window.open(this.href, '', 'height=430,width=600'); event.preventDefault();" class="ss-t"><span>Follow Us on Twitter</span></a>
	<div class="get-news"><span class="e">Get AutoGuide.com News Fast</span></div>
	<div class="form-sign-up">
		<form action="//email.autoguide.com/newsletter-signup/" method="post" class="recaptchav3_form newslettersignup-form">
			<input type="hidden" name="form[source]" value="wp_generic" />
			<input type="text" placeholder="Your Email Address" name="form[email]" required/>
			<input type="hidden" name="form[subscribeCheck]" required="required" value="1" />
            <input type="submit" class="button radius" value="Sign-up">
        </form>
	</div>
	<div class='vs-recaptcha-notification'>This site is protected by reCAPTCHA and the Google <a class='g-privacy-policy' href='https://policies.google.com/privacy'>Privacy Policy</a> and <a class='g-terms-of-service' href='https://policies.google.com/terms'>Terms of Service</a> apply.</div></div>
<!-- End New Social block sidebar -->

	<section class="section" id="comparisons">
        <h2 class="title">
		<a href="/car-comparisons/index.html">Car Comparisons</a>
		<div class="ad" id="AutoGuide_com_Compare_Sponsor_small_AUTO">
			<script type='text/javascript'>googletag.cmd.push(function() { deployads.push(function() {deployads.gpt.display('AutoGuide_com_Compare_Sponsor_small_AUTO'); }); });</script>
		</div>
	</h2>

        <div class="text_wrapper intro" >
            <div class="picture">
                <a href="https://www.autoguide.com/new-cars/2019/toyota/rav4/index.html"><img class="photo" src="/img/spacer.gif" data-original="https://www.autoguide.com/new-cars/images/nvd/2019/mediums/29471.jpg" width="130" height="65" alt="Compare - 2019 Toyota RAV4"></a>
                2019 Toyota RAV4            </div>
            <span class="vs"><a href="https://www.autoguide.com/car-comparisons/2019-toyota-rav4-vs-2019-subaru-forester">vs</a></span>
            <div class="picture">
                <a href="https://www.autoguide.com/new-cars/2019/subaru/forester/index.html"><img class="photo" src="/img/spacer.gif" data-original="https://www.autoguide.com/new-cars/images/nvd/2019/mediums/29087.jpg" width="130" height="65" alt="Compare - 2019 Subaru Forester"></a>
                2019 Subaru Forester            </div>

        </div>
        <!-- end intro -->


        <ul>

            <li><h3><a href="https://www.autoguide.com/car-comparisons/jeep-gladiator-rubicon-vs-ford-ranger-lariat-fx4" >Jeep Gladiator Rubicon vs Ford Ranger Lariat FX4</a></h3>
                <div class="text">
                    <span class="description" >Manufacturers of trucks are wising up. They seemed to have figured out that not everyone needs (or wants) an enormous Ramerado Latinum Carbon Lithium Edition pickup truck the size of three football fields. It is not uncommon for a truck buyer to want something with a rugged appearance. The bed, however, is used to haul air&#8230;</span>
                </div>
            </li>
            <li><h3><a href="https://www.autoguide.com/car-comparisons/toyota-camry-vs-hyundai-sonata-spec-comparison" >Toyota Camry vs Hyundai Sonata Spec Comparison</a></h3>
                <div class="text">
                    <span class="description" >Family sedans aren’t the biggest draw to showrooms these days, with crossovers and SUVs taking centre stage and providing most of the profits. Still, a few customers in the outfield (*raises hand*) prefer a four door car for their daily tasks.</span>
                </div>
            </li>
            <li><h3><a href="https://www.autoguide.com/car-comparisons/2020-nissan-altima-vs-2020-subaru-legacy-comparison" >2020 Nissan Altima vs 2020 Subaru Legacy Comparison</a></h3>
                <div class="text">
                    <span class="description" >Like the Cheshire Cat slowly vanishing from the Queen of Hearts&#8217; croquet field, the mid-size four-door sedan is disappearing from this country’s automotive marketplace. Two of the Detroit Three are busily pulling the plug on Fusion and Impala. And the Charger and 300 soldier on with underpinnings so old they could be carbon dated.</span>
                </div>
            </li>
            <li><h3><a href="https://www.autoguide.com/car-comparisons/hyundai-tucson-vs-kia-sportage-how-are-the-crossovers-different" >Hyundai Tucson vs Kia Sportage Comparison: Which One is Right for You?</a></h3>
                <div class="text">
                    <span class="description" >There are plenty of similarities between these two.</span>
                </div>
            </li>
            <li><h3><a href="https://www.autoguide.com/car-comparisons/2020-ford-escape-vs-2020-ford-edge-comparison" >2020 Ford Escape vs 2020 Ford Edge Comparison</a></h3>
                <div class="text">
                    <span class="description" >Two strong sellers for the Blue Oval, the Escape and Edge often make up a significant portion of dealership volume. For this model year, the smaller Escape has lost some of its chunky and squared-off charm in favor of more rounded bodywork. After receiving a boatload of changes last year, Edge soldiers on with no powertrain&#8230;</span>
                </div>
            </li>
   		</ul>
	</section>
<div class="ad" id="AutoGuide_com_300x250_Middle_AUTO">
<script type="text/javascript">
googletag.cmd.push(function() { deployads.push(function() {deployads.gpt.display('AutoGuide_com_300x250_Middle_AUTO'); }); });
</script>
</div>
<section class="text_wrapper section" id="top-promotion">

    <h2 class="title">Most Affordable Compact Crossovers</h2>
    <ol>
        <li><a href="https://www.autoguide.com/new-cars/2018/nissan/kicks/index.html">Nissan Kicks</a></li>
        <li><a href="https://www.autoguide.com/new-cars/2018/jeep/renegade/index.html">Jeep Renegade</a></li>
        <li><a href="https://www.autoguide.com/new-cars/2018/hyundai/kona/index.html">Hyundai Kona</a></li>
    </ol>

    <a href="https://www.autoguide.com/new-cars/2018/nissan/kicks/index.html"><img class="picture photo" src="/img/spacer.gif" data-original="https://www.autoguide.com/new-cars/images/nvd/2018/mediums/28487.jpg" width="130" height="65" alt="Most Affordable Compact Crossovers"></a>

</section>
<!-- end top-promotion -->

<div class="ad" id="AutoGuide_com_300x600_Right_AUTO">
<script type="text/javascript">
googletag.cmd.push(function() { deployads.push(function() {deployads.gpt.display('AutoGuide_com_300x600_Right_AUTO'); }); });
</script>
</div>
<section clas="section" id="car-buying-tools">
    <h2 class="title">Car Buying Tools</h2>
    <ul class="default" >
		<script type="text/javascript">
			googletag.cmd.push(function() { deployads.push(function() {deployads.gpt.display('AutoGuide_com_300x19_Sidebar1_AUTO'); }); });
		</script>
        <li><a target="_blank" href="/dealers/auto-dealers.html">Find a Dealer near your area</a></li>
        <li><a target="_blank" href="/new-cars/dealer-quotes.html">Free dealer Price Quote</a></li>
        <li><a target="_blank" href="/vehicle-history.html">Vehicle History Report</a></li>
    </ul>
</section>

<!-- sidebar_news sidebar from cache -->
</div><!-- div class=sidebar ends  -->

</aside>
<!-- right nav ends -->



</div>
<!-- end content -->



<div class="ad" id="Autoguide_com_300x250_Mobile_Bottom_AUTO">
<script type="text/javascript">
	googletag.cmd.push(function() { deployads.push(function() {deployads.gpt.display('Autoguide_com_300x250_Mobile_Bottom_AUTO'); }); });
</script>
</div>





    <!-- footer starts -->
    <footer id="footer" class="vsadspot noprint">

    <section class="section manufacturers-list" id="manufacturers">
<ul><li><a href="/new-cars/acura/index.html">Acura</a></li>
<li><a href="/new-cars/alfa-romeo/index.html">Alfa Romeo</a></li>
<li><a href="/new-cars/aston-martin/index.html">Aston Martin</a></li>
<li><a href="/new-cars/audi/index.html">Audi</a></li>
<li><a href="/new-cars/bentley/index.html">Bentley</a></li>
<li><a href="/new-cars/bmw/index.html">BMW</a></li>
<li><a href="/new-cars/buick/index.html">Buick</a></li>
<li><a href="/new-cars/cadillac/index.html">Cadillac</a></li>
<li><a href="/new-cars/chevrolet/index.html">Chevrolet</a></li>
<li><a href="/new-cars/chrysler/index.html">Chrysler</a></li>
<li><a href="/new-cars/dodge/index.html">Dodge</a></li>
<li><a href="/new-cars/faraday-future/index.html">Faraday Future</a></li>
<li><a href="/new-cars/ferrari/index.html">Ferrari</a></li>
<li><a href="/new-cars/fiat/index.html">Fiat</a></li>
<li><a href="/new-cars/ford/index.html">Ford</a></li>
<li><a href="/new-cars/genesis/index.html">Genesis</a></li>
<li><a href="/new-cars/gmc/index.html">GMC</a></li>
<li><a href="/new-cars/honda/index.html">Honda</a></li>
<li><a href="/new-cars/hyundai/index.html">Hyundai</a></li>
<li><a href="/new-cars/infiniti/index.html">Infiniti</a></li>
<li><a href="/new-cars/jaguar/index.html">Jaguar</a></li>
<li><a href="/new-cars/jeep/index.html">Jeep</a></li>
<li><a href="/new-cars/kia/index.html">Kia</a></li>
<li><a href="/new-cars/lamborghini/index.html">Lamborghini</a></li>
<li><a href="/new-cars/land-rover/index.html">Land Rover</a></li>
<li><a href="/new-cars/lexus/index.html">Lexus</a></li>
<li><a href="/new-cars/lincoln/index.html">Lincoln</a></li>
<li><a href="/new-cars/lotus/index.html">Lotus</a></li>
<li><a href="/new-cars/lucid-motors/index.html">Lucid Motors</a></li>
<li><a href="/new-cars/maserati/index.html">Maserati</a></li>
<li><a href="/new-cars/mazda/index.html">Mazda</a></li>
<li><a href="/new-cars/mclaren/index.html">McLaren</a></li>
<li><a href="/new-cars/mercedes-benz/index.html">Mercedes-Benz</a></li>
<li><a href="/new-cars/mini/index.html">Mini</a></li>
<li><a href="/new-cars/mitsubishi/index.html">Mitsubishi</a></li>
<li><a href="/new-cars/nissan/index.html">Nissan</a></li>
<li><a href="/new-cars/pagani/index.html">Pagani</a></li>
<li><a href="/new-cars/porsche/index.html">Porsche</a></li>
<li><a href="/new-cars/ram/index.html">Ram</a></li>
<li><a href="/new-cars/rivian/index.html">Rivian</a></li>
<li><a href="/new-cars/rolls-royce/index.html">Rolls-Royce</a></li>
<li><a href="/new-cars/smart/index.html">Smart</a></li>
<li><a href="/new-cars/subaru/index.html">Subaru</a></li>
<li><a href="/new-cars/tesla/index.html">Tesla</a></li>
<li><a href="/new-cars/toyota/index.html">Toyota</a></li>
<li><a href="/new-cars/volkswagen/index.html">Volkswagen</a></li>
<li><a href="/new-cars/volvo/index.html">Volvo</a></li>
</ul>    </section>

    <nav class="text-wrapper nav" id="footer-nav">
<ul><li class="hover" ><a href="/new-cars/">New Cars</a></li>
<li><a href="/used-cars/">Used Cars</a></li>
<li><a href="/manufacturer/car-reviews.html">Car Reviews</a></li>
<li class="hover" ><a href="/auto-news/">Auto News</a></li>
<li><a href="/auto-shows/">Auto Shows</a></li>
<li><a href="/forums.html">Forums</a></li>
</ul>    </nav>
    <nav class="text-wrapper subnav" id="footer-subnav">
    <span class="nav-wrapper-icon icon"><!-- -->&nbsp;</span>
<ul><li class="mobile-show" ><a href="/about-us.html">About Us</a></li>
<li class="mobile-show" ><a href="/staff.html">Editorial Staff</a></li>
<li class="mobile-show" ><a href="/contact-us.html">Contact Us</a></li>
<li><a href="/privacy-statement.html">Privacy Statement</a></li>
<li><a href="/terms-of-service.html">Terms of Service</a></li>
<li><a href="https://www.verticalscope.com/copyright.html?site=autoguide.com">Copyright</a></li>
<li><a href="/advertising-info.html">Advertising Info</a></li>
<li><a href="/site-map.html">Site Map</a></li>
<li class="hide-mobile"><a target="_blank" href="https://feeds.feedburner.com/autoguidefeed" class="rss">RSS</a></li>
</ul>    </nav>
    <span class="copywrite">    &copy; 2020 VerticalScope Inc. All rights reserved.
    </span>
</footer>
<!-- footer ends -->

<!-- footer from cache -->

</div>
<!-- end container -->



<div id='Autoguide_com_320x50_Mobile_Bottom_AUTO' class="ad" >
<script type='text/javascript'>
	googletag.cmd.push(function() { deployads.push(function() {deployads.gpt.display('Autoguide_com_320x50_Mobile_Bottom_AUTO'); }); });
</script>
</div>

<div id="upgradeIE" style="display: none;">
Your browser is out of date! Update your browser for free for improved security and a modern web browsing experience:
<br /><br />
<a href="https://windows.microsoft.com/en-US/internet-explorer/products/ie/home" target="_blank">Internet Explorer</a>,
<a href="https://www.google.com/chrome" target="_blank">Google Chrome</a> or
<a href="https://www.mozilla.org/en-US/firefox/fx/">Firefox</a>
</div>


<!-- 000 -->

<!--[if lt IE 9]>
<link rel="stylesheet" type="text/css" href="//www.autoguide.com/blog/wp-content/themes/autoguide/css/IE8.css?v=1536072107">
<script src="//www.autoguide.com/blog/wp-content/themes/autoguide/scripts/respond.min.js?v=1536072108"></script>
<![endif]-->

<script src="//www.autoguide.com/blog/wp-content/themes/autoguide/scripts/scripts-bottom.js?v=1536072108"></script>

<script src="//www.autoguide.com/blog/wp-content/themes/autoguide/scripts/scripts-defer.js?v=1543941052"></script>

<script type='text/javascript'>

setTimeout(function(){

var carCounter = 0;

var carCompareId = document.querySelector('.vsCompareCar iframe');
var startCarCompareMsg, carCompareFrame;

if (carCompareId) {
	carCompareFrame = carCompareId.contentWindow;
	startCarCompareMsg = setInterval(startCarCompare ,100);
}

	function startCarCompare() {
		carCompareFrame.postMessage({
			'ccMSg':'startCarCompare'
		},'*');

		carCounter++;

		if (carCounter === 33) {
			clearInterval(startCarCompareMsg);
		}
	};


	window.addEventListener('message', function(cce) {
	    if (cce.data.cceMsg === "carCompareReady") {

	     var ccAdData = JSON.parse(cce.data.ccData);


			 		if (ccAdData.adType == "vsCompareCar") {
			 			setFeaturedCompareVehicle(ccAdData.adData, ccAdData.adColumnNumber);


					} else if (ccAdData.adType == "vsCompareAfter") {

			 			setAdData(ccAdData.adData, ccAdData.adColumnNumber);
			 			compare4GetTechSpecs(ccAdData.adColumnNumber, ccAdData.adData.StyleID);
			    }

				clearInterval(startCarCompareMsg);

	     }
		});

		},500);

</script>



<!-- App pageFooterOnLoad begin -->

<!-- App pageFooterOnLoad end -->

<!-- moved from sidebar -->
<div class="spacer_ad" >
<script type='text/javascript'>
var timestamp = new Date().getTime();
document.write('<img src="https://ad.au.doubleclick.net/ad/N4492.138458.3815222641421/B6146002.16;sz=1x1;ord='+timestamp+'?" border="0" />');
</script>
</div>






<div class="ad" id="AutoGuide_com_1x1_Bottom_AUTO" style="width:1px;height:1px;">
<script type="text/javascript">
googletag.cmd.push(function() { deployads.push(function() {deployads.gpt.display('AutoGuide_com_1x1_Bottom_AUTO'); }); });
</script>
</div>


<script>
// for categories box on blog right nav, auto-news only
$(".all-categories-link").click(function() {
	  $("#all-categories").fadeToggle("fast", "linear");
	});
$(document).ready(function () {
    $('.sub_list-container ul.sub_list').easyListSplitter({colNumber: 3});
});

$(document).ready(function(){
	$('.prettyGallery').prettyGallery({'itemsPerPage':6});
});

/* temp Top10
----------------------------------*/
$(".category-top-10 .postbody img:first").parent().after("<div class=linkbar-move></div>");
$(".category-top-10 #social").appendTo(".linkbar-move");
$(".category-top-10 .byline").appendTo(".linkbar-move");
$(".category-top-10 .postbody h2").appendTo(".posttitle h2");
$(".category-top-10 .postbody h2").appendTo(".linkbar-move");
$(".category-top-10 .postbody h3").appendTo(".linkbar-move");
</script>




<!-- App pageFooterOnLoad2 begin -->

<!-- App pageFooterOnLoad2 end -->




<!-- ngg_resource_manager_marker --><script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"autoguidecom"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.autoguide.com/blog/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.16'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"815926 https:\/\/www.autoguide.com\/?p=815926","disqusShortname":"autoguidecom","disqusTitle":"How to Watch Every Racing Esport Event This Weekend","disqusUrl":"https:\/\/www.autoguide.com\/auto-news\/2020\/04\/how-to-watch-every-racing-esport-event-this-weekend.html","postId":"815926"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.autoguide.com/blog/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.16'></script>
<script type='text/javascript' src='https://www.autoguide.com/blog/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script type="text/javascript">
$(document).ready(function () {
	/* add custom css to nextgen gallery */
	var nextgenGallery=$("iframe.galleria-iframe");
	if (nextgenGallery.length){ // if gallery is found on the page
		nextgenGallery.bind("load", function() {
			var $head = nextgenGallery.contents().find("head");
			$head.append($("<link/>",
						{ rel: "stylesheet", href: '//www.autoguide.com/blog/wp-content/themes/autoguide/css/nextgen_custom.css', type: "text/css" }
					  ));
		});
	}
	var nextgenGalleryContent=$("#npl_content");
	if (nextgenGalleryContent.length){ // if gallery is found on the page
		nextgenGalleryContent.bind("load", function() {
			var $head = nextgenGalleryContent.contents().find("head");
			$head.append($("<link/>",
						{ rel: "stylesheet", href: '//www.autoguide.com/blog/wp-content/themes/autoguide/css/nextgen_custom.css', type: "text/css" }
					  ));
		});
	}
});
</script>

<!-- ConsolidatedFooters Footers -->
<!-- Adblock Check -->
<div class="afs_ads">&nbsp;</div>
<script>
(function() {
    var adBlockDetector = function() {
        setTimeout(function() {
            if (!document.getElementsByClassName) return;
            
            var ads = document.getElementsByClassName("afs_ads");
            ad  = ads[ads.length - 1];

            if (!ad || ad.innerHTML.length == 0 || ad.clientHeight === 0) {
                _gaq.push(["_trackEvent", "Adblock", "Blocked", "true",,true]);
            } else {
                ad.style.display = "none";
                _gaq.push(["_trackEvent", "Adblock", "Unblocked", "false",,true]);
            }

        }, 500);
    }

    /* Attach a listener for page load */
    if (window.addEventListener) {
        window.addEventListener("load", adBlockDetector, false);
    } else {
        window.attachEvent("onload", adBlockDetector); //IE
    }
})();
</script>
<!-- /Adblock Check--><!-- TOS DMCA -->
<style>
.tos_dmca_policy { text-align: center; }
.tos_dmca_policy table { display: inline-table; width: auto; }
.tos_dmca_policy table { display: inline-table; width: auto; margin: 0 10px; }
</style>
<div class="tfoot tos_dmca_policy">
<table cellpadding="3" cellspacing="0" border="0" class="page" align="center" width="100%"><tr><td class="tfoot" align="center" width="100%"><div class="smallfont"><strong><a rel="nofollow" href="http://www.verticalscope.com/aboutus/tos.php?site=autoguide.com">Terms of Use</a></strong></div></td></tr></table>

<!-- DMCA --><table cellpadding="3" cellspacing="0" border="0" class="page" align="center" width="100%"><tr><td class="tfoot" align="center" width="100%"><div class="smallfont"><strong><a rel="nofollow" href="http://www.verticalscope.com/copyright.html?site=autoguide.com">Copyright</a></strong></div></td></tr></table><!-- /DMCA -->
<!-- Privacy Policy --><table cellpadding="3" cellspacing="0" border="0" class="page" align="center" width="100%"><tr><td class="tfoot" align="center" width="100%"><div class="smallfont"><strong><a rel="nofollow" href="https://www.verticalscope.com/site-privacy-policy/index.php?site=autoguide.com">Privacy Policy</a></strong></div></td></tr></table><!-- /Privacy Policy -->
</div>
<!-- /TOS DMCA -->

<!-- UK legal cookies -->
<style>
.uk-cookie-popup {display:none;border: 2px solid #333; background: #f4f4f4; color: #333; Font-size: 11px; padding: 0px 10px 10px; line-height: normal; position: fixed; z-index: 1000001; bottom: 0px; left: 0px; width: 300px; max-width: 100%; margin: 2px; text-align: left; font-family: Arial;}
.uk-cookie-popup-title {margin: 0px -10px 10px; background: #333; color: #fff; padding: 5px 10px; font-weight: bold;}
.uk-cookie-popup a {color: #0983b6;}
.uk-cookie-popup a.uk-cookie-popup-close {float: right; color: #fff; font-size: 14px; display: inline-block; border: 1px solid #ccc; padding: 1px; line-height: 12px }
</style>
<div id="ukCookiePopup" class="uk-cookie-popup">
<div class="uk-cookie-popup-title"><span id="nointelliTXT"><a href="" class="uk-cookie-popup-close" onclick="setUkLegalCookie();return false;">x</a> Cookie and Data Use Consent</span></div>
<span id="nointelliTXT">We use cookies to improve your experience on this website and so that ads you see online can be tailored to your online browsing interests. We use data about you for a number of purposes explained in the links below.  By continuing to browse our site you agree to our use of data and cookies.<br /><a href="http://www.verticalscope.com/about-us/Data-Use-Consent-Notice.html?site=autoguide.com" rel="norewrite">Tell me more</a> | <a href="http://www.verticalscope.com/about-us/cookie-preferences.html?site=autoguide.com" rel="norewrite">Cookie Preferences</a></span>
</div>
<script>
function createCookie(name,value,days) {
    if (days) {
        var date = new Date();
        date.setTime(date.getTime()+(days*24*60*60*1000));
        var expires = "; expires="+date.toGMTString();
    }
    else var expires = "";

    document.cookie = name+"="+value+expires+"; path=/";
}

function readCookie(name) {
    var nameEQ = name + "=";
    var ca = document.cookie.split(";");
    for(var i=0;i < ca.length;i++) {
        var c = ca[i];
        while (c.charAt(0)==" ") c = c.substring(1,c.length);
        if (c.indexOf(nameEQ) == 0) return c.substring(nameEQ.length,c.length);
    }
    return null;
}

function eraseCookie(name) {
    createCookie(name,"",-1);
}

function setUkLegalCookie(){
    createCookie("uk-cookie-legal","been-shown",3650); //set cookie for 10 years
    document.getElementById("ukCookiePopup").style.display = "none";
}

//Add cookie consent tag functions to eu arrays.
function vsCFCookieConsentEU() {
	//Check if cookie has been set
	if (readCookie("uk-cookie-legal") == null) {
		//show popup
		document.getElementById("ukCookiePopup").style.display = "block";
	}
}

vsCFTagsEUFunctions.push(vsCFCookieConsentEU);
</script>
<!-- END UK legal cookies -->

<!-- GEOIP Footer -->
<script type="text/javascript">
//Check if GEOIP cookie exists.
if (vsCFIsEU === null) {
	vsCFIsEU = vsCFReadCookie("vsCFIsEU");
	vsCFUserGeoIP = vsCFReadCookie("vsCFUserGeoIP");
}

//Main checks to start new process or use existing data.
if (vsCFIsEU === null && (vsCFTagsEUFunctions.length > 0 || vsCFTagsNonEuFunctions.length > 0)) {
	vsCFSendAjax();
} else if (vsCFIsEU === false || vsCFIsEU === "false") {
	vsCFExecuteNonEuTags();
} else if (vsCFIsEU === true || vsCFIsEU === "true") {
	vsCFExecuteEuTags();
}
</script>
<!-- /GEOIP Footer -->

<!-- /ConsolidatedFooters Footers -->


<script>
$(document).ready(function() {
	var width = window.innerWidth || document.documentElement.clientWidth;

	if (width > 748) { // excluding mobile
		// Load auto-news sidebar contents and add it to the bottom
		$.ajax({
			url: "/blog/theme-cache/news-sidebar-bottom.php",
			success: function(data) {
				$('#sidebar').append($(data));
				$("#sidebar img.photo").lazyload({ threshold : 200 });
			}
		});
	}
});
</script>

<!--
************************************************************************
NEW GALLERY
************************************************************************
-->
<style>
  /* This rule is read by Galleria to define the gallery height:*/
  .galleria{height:100%; width:100%}
  .galleria-lightbox-wrapper {display:none; position:fixed; z-index:1000;top:0;bottom:0;left:0;right:0; text-align:center; width:100%; height:100%}
  .galleria-lightbox-wrapper:before{content:"";position:fixed; z-index:999; background:rgba(0,0,0,0.7);top: 0; bottom: 0; left: 0; right: 0;}
  .galleria-lightbox-wrapper .galleria{ margin:0 auto; display: inline-block; z-index: 1001; position: relative;}
  .galleria-lightbox-wrapper #close-galleria{position:absolute;top:8px; z-index:1005; right:8px; display:inline-block; border:2px solid #fff; width:33px; height:33px; cursor:pointer; color:#fff;line-height: 34px; font-size: 18px; text-align: center;}
</style>
<script type="text/javascript">
$(document).ready(function () {

                //Copy rg-gallery images to Galleria
                $(".es-carousel ul li img").each(function(i, item){
								$nearest_galleria = $(this).closest('div .rg-gallery').next('div .galleria-lightbox-wrapper').children('div .galleria');
                                $(this).clone().appendTo($nearest_galleria).wrap( "<a href='"+$(this).attr('data-xlarge')+"'></a>" );
                })
                //add close button
                $(".galleria-lightbox-wrapper").append(
                                                $('<span id="close-galleria">X</span>').click(function(){
                                                //Close galleria overlay
                                                $(".galleria-lightbox-wrapper").hide();
                                                Galleria.get(0).destroy();
                                                })
                );

                $('.btn-view-large').click(function(e){
                                e.stopPropagation();
                                var currentIndex=$(this).attr("data-current-index");
								$nearest_lightbox = $(this).closest('div .rg-gallery').next('div .galleria-lightbox-wrapper').show();
								$nearest_galleria = $(this).closest('div .rg-gallery').next('div .galleria-lightbox-wrapper').children('div .galleria');
                                // Initialize Galleria
                                Galleria.run($nearest_galleria,
											{
												transition: 'fade',
												height: '100%',
												show: currentIndex,

											});
                                return false;
                });

});
</script>


<!-- Taboola Footer -->
<div id="taboola-below-article-thumbnails---3"></div>
<script type="text/javascript">
function vsCFTaboolaFooterEU() {
	if (typeof googlefc == "object") {
			googlefc.callbackQueue.push(function() {
				if ( gfchelper.isAdProviderAllowed("taboola") ) {
					window._taboola = window._taboola || [];
					_taboola.push({flush: true});
				}
			});
	} else {
		console.log("cf: taboola googlefc not found.");
	}
}
function vsCFTaboolaFooterNonEU() {
    window._taboola = window._taboola || [];
	_taboola.push({flush: true});
}
//Add Taboola Footer tag functions to eu and non-eu arrays.
vsCFTagsEUFunctions.push(vsCFTaboolaFooterEU);
vsCFTagsNonEuFunctions.push(vsCFTaboolaFooterNonEU);
</script>
<!-- /Taboola Footer-->

<script type="text/javascript" src="https://shoppingtools-inline.invmrkt.com/Scripts/widget-inline.js?gid=0000-2762"></script>
</body>
</html>
